1. We are not accepting any new account registrations at this time.

DevExpress 18.2 - Smalltalk and Problems

Discussion in 'News, Freeware, Open Source and Discussions' started by JonArbuckle, Dec 2, 2018.

  1. JonArbuckle

    JonArbuckle is a Trusted Warez PosterJonArbuckle Administrator Staff Member Administrator DEV Guild Reverser

    Joined:
    Aug 12, 2017
    Messages:
    1,351
    Likes Received:
    11,528
    DevExpress 18.2

    Feel free to discuss here about working/not working things and problems.

    Don't post crack/patches!
     
  2. wa

    wan.janggut Registered User

    Joined:
    Nov 23, 2008
    Messages:
    283
    Likes Received:
    1,134
    At last.. thanks.. by the way why the medicine can not cure this time? Any theory ???
     
  3. no

    noplay Registered User

    Joined:
    Jul 31, 2009
    Messages:
    168
    Likes Received:
    2,258
    i guess we need new patch because dimaster memory patch is not working properly...and i am sure there are many talented reverser to make new patch easly in this forum.
     
  4. CyberKnight

    CyberKnight Restricted Member Banned User Restricted

    Joined:
    Apr 5, 2017
    Messages:
    1,425
    Likes Received:
    19,409
    Thanks for opening this thread ...:emoji_thumbsup:

    Anyone knows whether @dimaster is still active in this forum reading quietly or somewhere ? ;)
     
  5. Vietcode

    Vietcode is a Trusted Warez PosterVietcode The White Hat Staff Member Super Moderator DEV Guild Reverser Translator

    Joined:
    Nov 11, 2008
    Messages:
    4,779
    Likes Received:
    41,654
    He was here Oct 31,2018 ;)
     
  6. ke

    kesk Registered User

    Joined:
    Jan 2, 2007
    Messages:
    128
    Likes Received:
    2,742
    Win10 Pro + VS 2017 + DX 18.2.3 + Diamster patch 8 - I got 'Licensed' in the About box.

    If there is a problem, it is better to format the HDD, install a clean Windows, VS and DX. This has solved my issues all the time.
     
  7. RataMotchilera

    RataMotchilera is a Trusted Warez PosterRataMotchilera Registered User DEV Guild Reverser

    Joined:
    Dec 2, 2007
    Messages:
    127
    Likes Received:
    9,165
    Hi,

    For me : Windows 8.1 VS 2015 DXperience 8.2.3

    it works well when i delete "DevExpress.47ff551b#" folder from C:\Windows\assembly\NativeImages_v4.0.30319_32 otherwise i get trial nag screen.
    This folder contains : DevExpress.Datav18.2.ni.dll and DevExpress.Data.v18.2.ni.dll.aux
    The problem is that the folder is created randomly by windows 8.1 and i must delete it before lauching VS 2015 IDE. that's why i created batch file with below command and
    launch it before i start VS 2015 IDE:

    Code:
    rmdir /Q /S C:\Windows\assembly\NativeImages_v4.0.30319_32\DevExpress.47ff551b#
    Usually you have to look for these two files and delete them from NativeImages Directories.

    this behavior does not appear in windows 7 according to my tests

    I hope that it will help someone

    Regards.
     
    Last edited: Dec 2, 2018
  8. no

    noplay Registered User

    Joined:
    Jul 31, 2009
    Messages:
    168
    Likes Received:
    2,258

    how about when we deploy our program .. we still get random trail nag screen..
     
  9. RataMotchilera

    RataMotchilera is a Trusted Warez PosterRataMotchilera Registered User DEV Guild Reverser

    Joined:
    Dec 2, 2007
    Messages:
    127
    Likes Received:
    9,165
    No it works fine on prod machine if you build your application with well registred components as i mentioned above.
     
  10. gr

    grizzo Guest

    In my case the IDE shows "Trial Version" on component designer and the compiled version shows the nag screen.
    I resolved deleting all records on license.licx file before publish the assembly on production machine
     
  11. no

    noplay Registered User

    Joined:
    Jul 31, 2009
    Messages:
    168
    Likes Received:
    2,258
    beside after chaning date on production machine it show trail ...i dont know maybe iam doing something wrong
     
  12. al

    albx Registered User

    Joined:
    May 7, 2008
    Messages:
    49
    Likes Received:
    305
  13. al

    albx Registered User

    Joined:
    May 7, 2008
    Messages:
    49
    Likes Received:
    305
    thank you very much... this works!
     
  14. Ra

    Rangga Stephen Registered User

    Joined:
    Mar 12, 2017
    Messages:
    76
    Likes Received:
    650
    In my VS 2017, the component designer show Licensed (Winform), btw everytime before I compile@build my project I always remove licenses.licx manually from project properties..and so far No Nag Screen in client machine.
     
    Last edited: Dec 3, 2018
  15. wa

    wan.janggut Registered User

    Joined:
    Nov 23, 2008
    Messages:
    283
    Likes Received:
    1,134
    i have tried and it's working.. thanks for the tips
     
  16. ke

    kesk Registered User

    Joined:
    Jan 2, 2007
    Messages:
    128
    Likes Received:
    2,742
    Is it necessary to remove the licx file even when it shows Registered?

    I don't think so.

     
  17. An

    Andy Andyrade Registered User

    Joined:
    Feb 13, 2017
    Messages:
    5
    Likes Received:
    3

    Thank you.. It works in an instant.
     
  18. as

    ash Registered User

    Joined:
    Apr 28, 2008
    Messages:
    12
    Likes Received:
    499
    It works for me
    Windows 10 x64 2016, VS 2017 Community
     
  19. Fa

    FarSee Banned User Banned User

    Joined:
    Sep 9, 2018
    Messages:
    40
    Likes Received:
    164
    It works on
    Windows 10 x64, VS 2017 Enterprise, DevExpress v18.2.3
     
  20. Ri

    Riyadh811 Registered User

    Joined:
    Sep 7, 2018
    Messages:
    4
    Likes Received:
    0
    According to below advice: by ratamotchilera.


    delete "DevExpress.47ff551b#" folder from
    C:\Windows\assembly\NativeImages_v4.0.30319_32





    I've got licensed result on DevEpress 18.23 ,it's working as well with no issue.. Thanks guys for this sharing.