1. Account registrations are now closed.

LEGO Marvel Super Heroes 2 macOS

Discussion in 'Games' started by QueenKong, Nov 7, 2018.

  1. QueenKong

    QueenKong is a Trusted Warez PosterQueenKong wlan0 up Staff Member Super Moderator DEV Guild

    Joined:
    May 13, 2017
    Messages:
    6,552
    Likes Received:
    22,892
    [​IMG]

    LEGO Marvel Super Heroes 2 macOS

    Download
    Hidden Content:
    [HIDDEN CONTENT]
    It's about TIME! Join your favorite Super Heroes and Super Villains from different eras and realities as they go head-to-head with the time-traveling Kang the Conqueror in the all-new, original adventure, LEGO® Marvel Super Heroes 2! Play as the Guardians of the Galaxy, Spider-Man, Thor, Hulk, Black Panther, Captain Marvel, Doctor Strange, Green Goblin and dozens of other Marvel Super Heroes and Villains in this cosmic battle across the time-tossed city of Chronopolis! Travel across lands -- from Ancient Egypt to The Old West, Sakaar and New York City in 2099 -- and transport objects or characters through the centuries! And, with new battle modes, friends and family can play against each other in a series of themed challenges and battle arenas!

    System Requirements
    Minimum:
    Requires a 64-bit processor and operating system
    OS: macOS 10.13.5
    Processor: 1.8GHz Intel Core i3 or better
    Memory: 8 GB RAM
    Graphics: 1GB Nvidia 650M, 2GB AMD Radeon M290, Intel Iris Pro 5200 or better (see notes for more details)
    Storage: 25 GB available space
    Additional Notes: The game is supported on the following Macs. To check your Mac model and when it was released, select About This Mac from the Apple menu on your menu bar.
    * All 13" MacBook Pros released since 2016
    * All 15” Retina MacBook Pros released since Mid 2012
    * All 15" MacBook Pros released since Mid 2012 with a 1GB Graphics Card
    * All 21.5” iMacs released since Late 2013 with a 1.8GHz i3 processor or better
    * All 27” iMacs released since Late 2013 (1)
    * All 27" iMac Pros
    * All Mac Pros released since Late 2013
    1. Late 2012 models with a Nvidia 675MX or Nvidia 680MX graphics cards are also supported.
    Please note for your computer to meet the minimum requirements it must match or better all elements of the listed system requirements. For more detailed specifications check the Feral website. ———
    The following Macs are capable of running the game but do not consistently meet the standards required for official support.
    * All Mac Mini's since Late 2012
    * All 12" MacBooks released since Early 2016
    * All 13" MacBook Airs released since Mid 2012
    * All 13" MacBook Pros released since Mid 2012
    * All 13” Retina MacBook Pros released since Mid 2012
    * All 21’5” iMacs released since Early 2013

    [​IMG]

    [​IMG]
     
    IceZero and Lloyd Walker like this.