1. Important Notice: ALWAYS login to your account using Board4all.biz - we do not own or run any other websites so please make sure you are connected to our official domain, and that you see the secure connection padlock before entering your login details.

Windows 10 Creators Update makes WiFi slow, suggestions?

Discussion in 'SW Helpdesk' started by Ph!d, Aug 24, 2017.

  1. Ph!d

    Ph!d is a Trusted Warez PosterPh!d Board Protector Staff Member Administrator DEV Guild Reverser Translator

    Joined:
    Sep 11, 2008
    Messages:
    62,285
    Likes Received:
    125,358
    I've been searching for weeks or months (not always, just when I'm using this computer lol) for a solution to the slow download speed when using WiFi with Windows 10 Creators Update (1703) and haven't got any of the posted solutions to work on my side.

    Apparently it is a well know issue (just Google it) and most of the results points to an issue related to QoS.

    I've reverted all the fixes I tired (registry tweaks, tweaks to the card config, ...) and just leaved the updated drivers just to try (hopefully) some proposed solution from scratch.

    I've 2 wifi cards, an integrated one in the laptop and an USB one (new one). With both I experience slow download speeds. Instead of downloading at 2.7Mbps I download at around 100-200kbps.

    Connection to the ethernet works wonders and I get the 2.7Mbps download speed but the router is far away and I would like to have my WiFi working in Windows (until I get my hands on a powerline :p).

    Tested with Linux in the same machine and both cards work so is not a hardware issue.
    Also, my Windows upgraded by itself to the Creators Update and dummy I removed the old version so reinstalling is not an option right now (too lazy to reinstall all I need).

    So if you guys have any suggestion or maybe someone got the same issue and fixed it, I'm all eyes.
    Thanks in advance!
     
  2. Ph!d

    Ph!d is a Trusted Warez PosterPh!d Board Protector Staff Member Administrator DEV Guild Reverser Translator

    Joined:
    Sep 11, 2008
    Messages:
    62,285
    Likes Received:
    125,358
    Just a heads up, the Fall Creators Update (RS3) released yesterday fixed the issue! WiFi is finally back to normal :)
    Lets see what got broken now...
     
    hacker7, chenke, Gary and 2 others like this.
  3. so

    soliver84 Registered User

    Joined:
    Oct 30, 2017
    Messages:
    11
    Likes Received:
    27
    Uknow007, hacker7 and chenke like this.
  4. ha

    hairypaulsack Registered User

    Joined:
    Sep 30, 2017
    Messages:
    20
    Likes Received:
    73
    As counter-intuitive as this is going to seem, just try it.
    Mind you I don't have problems and am just relaying information

    1. Enable adapter and connect to network in question
    2. Open new win10 'Settings' (not Control Panel)
    3. Click 'Network and Internet'
    4. Take route depending on how yours looks (either anniversary or creators update changed this up)
      • METHOD 1
      1. Under left vertical menu click 'WiFi'
      2. Click blue option 'Manage known networks'
      3. Click your network, then on properties
      4. Enabled Metered Connection
      • METHOD 2 (Older style, before the menu alterations)
      1. After clicking Network and Internet you should be on the WiFI tab already.
      2. Click Advanced Settings
      3. Enable Metered Connection

    Right I know, I know, seems it would have the opposite effect, but the YouTube comments speak for themselves. (Personally I think they are all fucking idiots and don't know a damn about anything, but I wouldn't claim they are lying due to the shear number of thanks etc.)

    If you respond to this then I will look into the actual cause of the problem, because this certainly is not the issue.
    Unless the put the switch backwards hahaha. On (blue) = OFF && Off (white) = ON


    Regardless grab the SDI-Driver tool because it's a gift from the geek gods. An actual driver identifier, finder, downloaded that doesn't give you any bullshitware

    Don't forget it's always easier to google something b4 asking on a forum, that video was the first returned result, lucky for me it was the first I tried unlike some of the others.. again, see the comments. Also, videos usually aren't the go-to for finding fixes, but it does sometimes help!
     
    Uknow007, vladyka, hacker7 and 2 others like this.
  5. sa

    sachinaut Registered User

    Joined:
    Oct 18, 2008
    Messages:
    150
    Likes Received:
    805
    WiFi driver is buggy, i have to disable and re-enable network adapter to get it to full speed sometimes - esp when network resumes
     
  6. sa

    sachinaut Registered User

    Joined:
    Oct 18, 2008
    Messages:
    150
    Likes Received:
    805
    Believe me there are a lot of WiFi driver issue on Windows 10. Due to revised device driver model most hardware gives issues. Try to update it to RS5 (1803) for least issues. When network adapter is not detect - try to disable "enable power saving for this device" in device driver settings.
     
    dbpreston likes this.
  7. Azertyjo

    Azertyjo Registered User

    Joined:
    Jul 17, 2017
    Messages:
    27
    Likes Received:
    139
    99% of windows versions have the setting for network not configured for speed. As commented before, donwload program from here:

    https://www.speedguide.net/downloads.php

    and let it reconfigure your network adaptors.

    Huge difference
     
    dbpreston likes this.
  8. ha

    hairypaulsack Registered User

    Joined:
    Sep 30, 2017
    Messages:
    20
    Likes Received:
    73
    Is this automated or you have a guide to follow?
     
  9. Azertyjo

    Azertyjo Registered User

    Joined:
    Jul 17, 2017
    Messages:
    27
    Likes Received:
    139
    Automated but you can also tweak settings manually.